summaryrefslogtreecommitdiff
path: root/dev-util/glslang/glslang-1.3.243.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-06 11:27:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-06 11:27:38 +0100
commitefca56beb6bbb9547d49163cac02eac0b5c1f657 (patch)
tree8bf6231248f07665ec95268dc33bf4acfde82f63 /dev-util/glslang/glslang-1.3.243.ebuild
parent99d38fd80dbcd05d7ac05f9fbc86c396bacd5f7c (diff)
gentoo auto-resync : 06:04:2023 - 11:27:37
Diffstat (limited to 'dev-util/glslang/glslang-1.3.243.ebuild')
-rw-r--r--dev-util/glslang/glslang-1.3.243.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/glslang/glslang-1.3.243.ebuild b/dev-util/glslang/glslang-1.3.243.ebuild
new file mode 100644
index 000000000000..c00807a5549c
--- /dev/null
+++ b/dev-util/glslang/glslang-1.3.243.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SNAPSHOT_COMMIT="sdk-${PV}.0"
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${SNAPSHOT_COMMIT}"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0/12"
+
+# Bug 698850
+RESTRICT="test"
+
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3.236-Install-static-libs.patch" )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PCH=OFF
+ )
+ cmake_src_configure
+}