summaryrefslogtreecommitdiff
path: root/dev-util/glslang/glslang-1.3.231.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 03:08:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 03:08:46 +0000
commit29badda007a3bcd85bb351f602790eb3b8922448 (patch)
treec61f9e929e2bf3796366d57707eda3245586ce7a /dev-util/glslang/glslang-1.3.231.ebuild
parentc37d894982b59595356319a2b4655fed277097ae (diff)
gentoo auto-resync : 02:11:2022 - 03:08:46
Diffstat (limited to 'dev-util/glslang/glslang-1.3.231.ebuild')
-rw-r--r--dev-util/glslang/glslang-1.3.231.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/glslang/glslang-1.3.231.ebuild b/dev-util/glslang/glslang-1.3.231.ebuild
new file mode 100644
index 000000000000..a87aaeeb9345
--- /dev/null
+++ b/dev-util/glslang/glslang-1.3.231.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SNAPSHOT_COMMIT="sdk-${PV}.0"
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${SNAPSHOT_COMMIT}"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+# Bug 698850
+RESTRICT="test"