summaryrefslogtreecommitdiff
path: root/dev-util/glib-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-util/glib-utils
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-util/glib-utils')
-rw-r--r--dev-util/glib-utils/Manifest4
-rw-r--r--dev-util/glib-utils/glib-utils-2.52.3.ebuild15
-rw-r--r--dev-util/glib-utils/glib-utils-2.56.2.ebuild43
-rw-r--r--dev-util/glib-utils/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/glib-utils/Manifest b/dev-util/glib-utils/Manifest
new file mode 100644
index 000000000000..a81ac96619c1
--- /dev/null
+++ b/dev-util/glib-utils/Manifest
@@ -0,0 +1,4 @@
+DIST glib-2.56.2.tar.xz 8041756 BLAKE2B 1af5bb37378856e959602bcb9299266bba46b990839c923f6b9881624aed306af0779005281b3e3a46b5994c54812edc86aade9cb782c596fd63b6fd91baba51 SHA512 8201ea82d3613d2e879284abe01520b766da30957c5a1a22f3e6019b0cce6bf95d25beae78867b6a133401c4165153c0c92974dd459ab12f9e0e9dd0c95df5d4
+EBUILD glib-utils-2.52.3.ebuild 479 BLAKE2B 470fc81c8c561d7877c888eb94a91a161989f47935ff9f709843fda0cdde77402cd672efe94a55fa0bee649553749612b1273e0391a18607108c5d7837299c1d SHA512 d6698c0a179f0bc645d74e205601a175ccf95e63cb0da8bfe2b07a2c8d6a4222a69def4d9dded8c7f09b435a1b7d56eece1bf57612d12fa47a743cff3225d5db
+EBUILD glib-utils-2.56.2.ebuild 1300 BLAKE2B 5df0d0cb06c47aad00450271a5734c97303b0558f89dfee7a74d2424640c69f6f9fabbde97d48bb60229102bb52ed16ffa6be8ddbab7709be2ffef7c6384b42b SHA512 ccd4fedc7f346460f429cd4169f5eae76c0638a778f54e88ca974033f9a965d45b34fa9798580c61422b30e0f40c2cb78b83856e6f70fda26759ac9b918131a9
+MISC metadata.xml 332 BLAKE2B 1e3c081ae9a2c8ae53cee6c3ae133cbd5e8543a68c03d4a4f7e164437502d996ea9364789e93114687271e1f472bcf13a418cca5b74ecb95a51849f0a5f3dafa SHA512 f7680d9be4071b841f50ece99b5041dc492901d84ae05383c1ff05b6a73bab804b153a50eb70f5417137f6e2041230c5ba8eaede10f7a0bf8a899508642588c6
diff --git a/dev-util/glib-utils/glib-utils-2.52.3.ebuild b/dev-util/glib-utils/glib-utils-2.52.3.ebuild
new file mode 100644
index 000000000000..bbc78a7fd93d
--- /dev/null
+++ b/dev-util/glib-utils/glib-utils-2.52.3.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Build utilities for GLib using projects"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0" # /usr/bin utilities that can't be parallel installed by their nature
+IUSE=""
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+RDEPEND="dev-libs/glib:2"
diff --git a/dev-util/glib-utils/glib-utils-2.56.2.ebuild b/dev-util/glib-utils/glib-utils-2.56.2.ebuild
new file mode 100644
index 000000000000..94ec6c5e79f8
--- /dev/null
+++ b/dev-util/glib-utils/glib-utils-2.56.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+GNOME_ORG_MODULE="glib"
+
+inherit gnome.org python-single-r1
+
+DESCRIPTION="Build utilities for GLib using projects"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0" # /usr/bin utilities that can't be parallel installed by their nature
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+RDEPEND="${PYTHON_DEPS}
+ !<dev-libs/glib-2.56.2:2
+"
+DEPEND="${RDEPEND}"
+
+src_configure() { :; }
+
+src_compile() {
+ sed -e "s:@VERSION@:${PV}:g;s:@PYTHON@:python:g" gobject/glib-genmarshal.in > gobject/glib-genmarshal
+ sed -e "s:@VERSION@:${PV}:g;s:@PYTHON@:python:g" gobject/glib-mkenums.in > gobject/glib-mkenums
+}
+
+src_install() {
+ python_fix_shebang gobject/glib-genmarshal
+ python_fix_shebang gobject/glib-mkenums
+ python_fix_shebang glib/gtester-report
+ exeinto /usr/bin
+ doexe gobject/glib-genmarshal
+ doexe gobject/glib-mkenums
+ doexe glib/gtester-report
+ doman docs/reference/gobject/glib-genmarshal.1
+ doman docs/reference/gobject/glib-mkenums.1
+ doman docs/reference/glib/gtester-report.1
+}
diff --git a/dev-util/glib-utils/metadata.xml b/dev-util/glib-utils/metadata.xml
new file mode 100644
index 000000000000..0da0d356cb57
--- /dev/null
+++ b/dev-util/glib-utils/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:gnome:glib</remote-id>
+ </upstream>
+</pkgmetadata>