summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli/gitlab-cli-1.31.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 04:28:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 04:28:45 +0100
commit7e110ec617b903791c3d309845e11a8b27f441cc (patch)
treed9e8b4826e21ef9fa1fc2255d459f563d5581283 /dev-util/gitlab-cli/gitlab-cli-1.31.0.ebuild
parentf2a91413828611d85d0496e98e1656e9b0e4528b (diff)
gentoo auto-resync : 11:07:2023 - 04:28:45
Diffstat (limited to 'dev-util/gitlab-cli/gitlab-cli-1.31.0.ebuild')
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.31.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.31.0.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.31.0.ebuild
new file mode 100644
index 000000000000..0562e5401e38
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.31.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=1f8464b403a4611ef689a89893cb700718abdb20
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}