summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 17:13:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 17:13:02 +0100
commit670fe3b64a21a723fda1e52fe61cad2327f81f67 (patch)
treee6699a97f6776ef2588129c3ad5b895621d4e4aa /dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild
parent7aa28e7310855bc5ef0d32b22e8b58eec55c28c9 (diff)
gentoo auto-resync : 28:04:2023 - 17:13:02
Diffstat (limited to 'dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild')
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild
new file mode 100644
index 000000000000..bac5430a1390
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.28.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=815d2622473028a14de7db77728a6d7cda467946
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}