summaryrefslogtreecommitdiff
path: root/dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild')
-rw-r--r--dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild b/dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild
index 77063dce38e6..21e4ca76bf1a 100644
--- a/dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild
+++ b/dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild
@@ -1,15 +1,20 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1 pypi
DESCRIPTION="A documentation generator for GObject-based libraries"
-HOMEPAGE="https://gitlab.gnome.org/GNOME/gi-docgen https://pypi.org/project/gi-docgen/"
+HOMEPAGE="
+ https://gitlab.gnome.org/GNOME/gi-docgen
+ https://pypi.org/project/gi-docgen/
+"
LICENSE="|| ( Apache-2.0 GPL-3+ ) CC0-1.0 OFL-1.1 MIT"
SLOT="0"
@@ -27,8 +32,7 @@ RDEPEND="
')
$(python_gen_cond_dep '
dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
+ ' 3.10)
"
-DEPEND="${RDEPEND}"
distutils_enable_tests pytest