summaryrefslogtreecommitdiff
path: root/dev-util/gcovr/gcovr-4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-util/gcovr/gcovr-4.2.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-util/gcovr/gcovr-4.2.ebuild')
-rw-r--r--dev-util/gcovr/gcovr-4.2.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/dev-util/gcovr/gcovr-4.2.ebuild b/dev-util/gcovr/gcovr-4.2.ebuild
index 580ac995f399..fc1fc53cd521 100644
--- a/dev-util/gcovr/gcovr-4.2.ebuild
+++ b/dev-util/gcovr/gcovr-4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -15,21 +15,16 @@ SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/PyUtilib[${PYTHON_USEDEP}]
- )
+BDEPEND="
+ test? ( dev-python/PyUtilib[${PYTHON_USEDEP}] )
"
# tests fail on gcc newer than 5.8
-# https://github.com/gcovr/gcovr/issues/206
RESTRICT="test"
distutils_enable_tests pytest
@@ -40,5 +35,11 @@ python_test() {
local -x PATH="${TEST_DIR}/scripts:${PATH}" \
PYTHONPATH="${TEST_DIR}/lib"
- pytest -vv gcovr || die "Tests fail with ${EPYTHON}"
+ local deselect=(
+ # those tests fail on gcc newer than 5.8
+ # https://github.com/gcovr/gcovr/issues/206
+ gcovr/tests/test_gcovr.py
+ )
+
+ epytest gcovr ${deselect[@]/#/--deselect }
}