summaryrefslogtreecommitdiff
path: root/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild')
-rw-r--r--dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild b/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
new file mode 100644
index 000000000000..2e8142c44fce
--- /dev/null
+++ b/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV=$(delete_version_separator _)
+
+DESCRIPTION="FTJam is a 100% compatible, enhanced implementation of the make alternative Jam"
+HOMEPAGE="http://freetype.sourceforge.net/jam/index.html"
+SRC_URI="http://david.freetype.org/jam/ftjam-${MY_PV}.tar.bz2"
+
+LICENSE="perforce GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="!dev-util/jam
+ sys-devel/bison"
+RDEPEND="!dev-util/jam"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.5.3-nostrip.patch
+ epatch "${FILESDIR}"/${PN}-2.5.3-i-hate-yacc.patch
+ epatch "${FILESDIR}"/${PN}-2.5.3-false-flags.patch
+# epatch "${FILESDIR}"/${PN}-2.5.3-debug-commandline.patch # development only
+}
+
+src_compile() {
+ tc-export CC
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README README.ORG CHANGES INSTALL RELNOTES
+ dohtml Jam.html Jambase.html Jamfile.html
+}