summaryrefslogtreecommitdiff
path: root/dev-util/flawfinder/flawfinder-2.0.19-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-31 23:51:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-31 23:51:54 +0000
commitbf90f82fef4fc737c88b58cd31428ad4355c17fa (patch)
treefc72ac72a2f48adcbc9b83d64185c7747727566a /dev-util/flawfinder/flawfinder-2.0.19-r1.ebuild
parent027dc9b3977cd14e0c7ae52e7bf9370c3919afa1 (diff)
gentoo auto-resync : 31:12:2023 - 23:51:53
Diffstat (limited to 'dev-util/flawfinder/flawfinder-2.0.19-r1.ebuild')
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.19-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/flawfinder/flawfinder-2.0.19-r1.ebuild b/dev-util/flawfinder/flawfinder-2.0.19-r1.ebuild
new file mode 100644
index 000000000000..d6b63ad8c62f
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.19-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.18-setup.patch )
+
+src_prepare() {
+ sed -e "s/${PN}.1.gz/${PN}.1/g" -i setup.py || die 'sed failed'
+ default
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}