summaryrefslogtreecommitdiff
path: root/dev-util/flawfinder/flawfinder-2.0.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-util/flawfinder/flawfinder-2.0.17.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-util/flawfinder/flawfinder-2.0.17.ebuild')
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.17.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/flawfinder/flawfinder-2.0.17.ebuild b/dev-util/flawfinder/flawfinder-2.0.17.ebuild
new file mode 100644
index 000000000000..9305ed78d86a
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
+ default
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}