summaryrefslogtreecommitdiff
path: root/dev-util/flatpak-builder/flatpak-builder-1.2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 06:56:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 06:56:15 +0000
commit1536d928ae095e00db8775fecca580c10adc0af8 (patch)
treece87fe174db749dca9fac4dcd229d263a03f47c4 /dev-util/flatpak-builder/flatpak-builder-1.2.2-r1.ebuild
parent0e33d150b98b9f2354c92788ef9dc739850b40f6 (diff)
gentoo auto-resync : 17:11:2022 - 06:56:15
Diffstat (limited to 'dev-util/flatpak-builder/flatpak-builder-1.2.2-r1.ebuild')
-rw-r--r--dev-util/flatpak-builder/flatpak-builder-1.2.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/flatpak-builder/flatpak-builder-1.2.2-r1.ebuild b/dev-util/flatpak-builder/flatpak-builder-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..262070de405e
--- /dev/null
+++ b/dev-util/flatpak-builder/flatpak-builder-1.2.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+DESCRIPTION="Tool to build flatpaks from source"
+HOMEPAGE="http://flatpak.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc +yaml"
+
+RDEPEND="
+ >=sys-apps/flatpak-0.99.1
+ >=dev-util/ostree-2019.5:=
+ >=net-libs/libsoup-2.4:2.4=
+ >=dev-libs/elfutils-0.8.12:=
+ >=dev-libs/glib-2.44:2=
+ >=dev-libs/libxml2-2.4:=
+ dev-libs/json-glib:=
+ net-misc/curl:=
+ yaml? ( dev-libs/libyaml:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.18.2
+ virtual/pkgconfig
+ doc? (
+ app-text/xmlto
+ dev-libs/libxslt
+ )
+"
+
+PATCHES=("${FILESDIR}/flatpak-builder-1.2.2-musl.patch")
+
+src_configure() {
+ econf \
+ $(use_enable doc documentation) \
+ $(use_enable doc docbook-docs) \
+ $(use_with yaml)
+}