summaryrefslogtreecommitdiff
path: root/dev-util/fhist/files/fhist-1.21-ldflags.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/fhist/files/fhist-1.21-ldflags.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/fhist/files/fhist-1.21-ldflags.patch')
-rw-r--r--dev-util/fhist/files/fhist-1.21-ldflags.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/fhist/files/fhist-1.21-ldflags.patch b/dev-util/fhist/files/fhist-1.21-ldflags.patch
new file mode 100644
index 000000000000..00aab69d7495
--- /dev/null
+++ b/dev-util/fhist/files/fhist-1.21-ldflags.patch
@@ -0,0 +1,40 @@
+ Makefile.in | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index ba4e4c2..c0e552a 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -916,8 +916,8 @@ common/libcommon.a: $(common_obj)
+ fcomp_obj = fcomp/main.$(OBJEXT)
+
+ bin/fcomp$(EXEEXT): $(fcomp_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fcomp_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fcomp_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fcomp$(EXEEXT): bin/fcomp$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fcomp$(EXEEXT) $@
+@@ -928,8 +928,8 @@ fhist_obj = fhist/breaks.$(OBJEXT) fhist/diff.$(OBJEXT) fhist/extract.$(OBJEXT)
+ fhist/subroutine.$(OBJEXT) fhist/update.$(OBJEXT)
+
+ bin/fhist$(EXEEXT): $(fhist_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fhist_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fhist_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fhist$(EXEEXT) $@
+@@ -937,8 +937,8 @@ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ fmerge_obj = fmerge/main.$(OBJEXT) fmerge/work.$(OBJEXT)
+
+ bin/fmerge$(EXEEXT): $(fmerge_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fmerge_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fmerge_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fmerge$(EXEEXT): bin/fmerge$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fmerge$(EXEEXT) $@