summaryrefslogtreecommitdiff
path: root/dev-util/envman/envman-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-23 00:11:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-23 00:11:31 +0100
commitbff543bb632933380da922cbfc07c67157d72d42 (patch)
treedf2e5eebc3dbd8e29153ab3a869b3be8d9be9f19 /dev-util/envman/envman-2.1.1.ebuild
parent491d0101c89d81dec507f28215b3cb094800d600 (diff)
gentoo auto-resync : 23:06:2024 - 00:11:30
Diffstat (limited to 'dev-util/envman/envman-2.1.1.ebuild')
-rw-r--r--dev-util/envman/envman-2.1.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-util/envman/envman-2.1.1.ebuild b/dev-util/envman/envman-2.1.1.ebuild
deleted file mode 100644
index 6b28de28dfe1..000000000000
--- a/dev-util/envman/envman-2.1.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-build
-
-EGO_ON="github.com/bitrise-io"
-EGO_PN="${EGO_ON}/${PN}"
-
-DESCRIPTION="Environment variable manager for Bitrise CLI"
-HOMEPAGE="https://app.bitrise.io/cli"
-SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-S="${WORKDIR}/src/${EGO_ON}/${PN}"
-
-src_unpack() {
- default
- mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
- mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/envman" || die "Couldn't move sources to GOPATH"
-}
-
-src_compile() {
- GOPATH="${WORKDIR}" go build -v -o bin/envman || die "Couldn't compile envman"
-}
-
-src_test() {
- GOPATH="${WORKDIR}" go test ./... || die "Tests failed"
-}
-
-src_install() {
- dobin bin/envman
- einstalldocs
-}