summaryrefslogtreecommitdiff
path: root/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-util/ebuildtester/ebuildtester-0.1.29.ebuild
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-util/ebuildtester/ebuildtester-0.1.29.ebuild')
-rw-r--r--dev-util/ebuildtester/ebuildtester-0.1.29.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild b/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild
new file mode 100644
index 000000000000..b6204349693b
--- /dev/null
+++ b/dev-util/ebuildtester/ebuildtester-0.1.29.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
+HOMEPAGE="https://ebuildtester.readthedocs.io/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emulation/docker
+ sys-fs/fuse
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" "${PN}"
+}