summaryrefslogtreecommitdiff
path: root/dev-util/dput-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-util/dput-ng
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-util/dput-ng')
-rw-r--r--dev-util/dput-ng/Manifest2
-rw-r--r--dev-util/dput-ng/dput-ng-1.32.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/dput-ng/Manifest b/dev-util/dput-ng/Manifest
index 5dc8f7c882ae..2e4be7e995f0 100644
--- a/dev-util/dput-ng/Manifest
+++ b/dev-util/dput-ng/Manifest
@@ -1,3 +1,5 @@
DIST dput-ng_1.28.tar.xz 85276 BLAKE2B d205d15aad1b81dcf2cc0b765c9724b21add32df39102b63502d99e5da73aa95efdf66e94f6226105ab2ae97a4bf8c43963784f3ddf2d03217ab5023a7a98f22 SHA512 cfd4a6143b33f29eb32b88972a204ab7a6c2f062299c76167434322ae5d6d2cf8654c5b4d1e96db90dbffe372a04e2a7691694ecf46787c7743dd9ac2b7b317e
+DIST dput-ng_1.32.tar.xz 86280 BLAKE2B 7e195eab4f48d77968b866185e337f2b51113f7e11cfa4929d47e79082c2fa866af2c8394c50816b650f865db9ef244775618a05a6b398090366d342a45a3db7 SHA512 596247eecb2dce080cd6f3cd1ddb1364cfa00fc3048081149e4d6dc35822aee10fa10ec25ed91154b477a909cc29dcf17cb38ccefa649f40eb70c16e0a575b2e
EBUILD dput-ng-1.28-r1.ebuild 1879 BLAKE2B a089ff7d09249df94644d9895d1758c3522034f953f3b67c5cb0a1ad5e1fb16d6dfaed04466a386b97f18489f3ad64eecb4e94769a89a8e34eb178261e69ebc0 SHA512 90effe3d5955c3efeb248534ccfe60ca0014a2420a6ecf91b1bb4a25a2d367e241f3bfbf124a95d3b7126b1ecb629e871be5407bef3766be67c844fbb7958497
+EBUILD dput-ng-1.32.ebuild 1887 BLAKE2B 1bc7632022db9a31432a0e0aff656dd85ed98285e5bba4db7f396fc5f4932df74257bd3def1e254b2f5fdd56aba0988f9901925cd88040636d58ba3c961d2c3e SHA512 d3821e7902422740155533c50f24751427c0518f4a1af1417683ef9b470c9aa999e458333dd3d98a0bfcfa4d4266cb0367162ace06f51c60914c679dba3b29f2
MISC metadata.xml 367 BLAKE2B 867a3664c5bbd444d69af80af19994e07e3810349258e85c2afd0c838cb140aa3f3342ee1aa5e6862d1fd5130e7e09c1f9f30443827fe7df705f4273694c0784 SHA512 3eb0be47e7eb6bfb6d8eecee66a25183da436c38272e226e7819c8748774f3aae620eab7227414cb862734d4baf8fa060290c1b2371233141abcffd7b489c7b8
diff --git a/dev-util/dput-ng/dput-ng-1.32.ebuild b/dev-util/dput-ng/dput-ng-1.32.ebuild
new file mode 100644
index 000000000000..62870638d55b
--- /dev/null
+++ b/dev-util/dput-ng/dput-ng-1.32.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Next generation Debian package upload tool"
+HOMEPAGE="https://people.debian.org/~paultag/dput-ng/"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-debian[${PYTHON_MULTI_USEDEP}]
+ dev-python/paramiko[${PYTHON_MULTI_USEDEP}]
+ dev-util/distro-info[python,${PYTHON_MULTI_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ dev-python/python-debian[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-util/debhelper
+ )"
+
+# Requires missing build-essential package
+RESTRICT="test"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ mkdir man || die
+ for file in docs/man/*.man; do
+ a2x --doctype manpage --format manpage -D man \
+ "${file}" || die
+ done
+}
+
+src_install() {
+ local DPUT_BINARIES=( dcut dirt dput )
+ local DPUT_ETC=( metas profiles )
+ local DPUT_SHARE=(
+ codenames
+ commands
+ hooks
+ interfaces
+ schemas
+ uploaders
+ )
+
+ distutils-r1_src_install
+
+ for binary in ${DPUT_BINARIES[@]}; do
+ dobin bin/"${binary}"
+ done
+ python_fix_shebang "${D}"/usr/bin
+
+ insinto /etc/dput.d
+ for dir in ${DPUT_ETC[@]}; do
+ doins -r skel/"${dir}"
+ done
+
+ insinto /usr/share/"${PN}"
+ for dir in ${DPUT_SHARE[@]}; do
+ doins -r skel/"${dir}"
+ done
+
+ # doman incorrectly treats "cf" in dput.cf.5 as a lang code
+ doman -i18n="" man/*
+
+ newbashcomp debian/dcut-completion dcut
+ newbashcomp debian/dput-completion dput
+}
+
+python_test() {
+ # test_configs.py failing
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824652
+ nosetests || die "Tests failed under ${EPYTHON}"
+}