summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-util/diffoscope
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-129.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index edb6106cf908..62ef12d9e360 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
+DIST diffoscope-129.tar.gz 1766281 BLAKE2B 7e5dfc66a20daa62783811ec6f57b32b0733c65d66d9a17379985d5a18cf0e8b2901cf49a28d72f9305b2721e10c6ac455d747dbf5b5f3b9773c63b7fee0cd5b SHA512 2c472485b594cf2fb424bed52233a422e643bf8d5d8c919b5b5ce20c83ec7345325d337bb188c1a860f85f777012bd3e0137721a418903e0d421d4fe2d5a1b08
DIST diffoscope-87.tar.gz 1026242 BLAKE2B 5055607c21504bf05f71793b112c1452556ac41e4c193c68fc037ab8089745e9b10dddc04b396f2011d22468e00a07392723631021d062f59935a953effd04fa SHA512 9f46ca0ba52ee991547c1b2b2477bab1e0c065cebf96649cecafc0e78983f42fe18b012a1f17de6184decb6cbb49aede91445c75777cfb292c6abe8bdf2dd6b6
DIST diffoscope-88.tar.gz 1027126 BLAKE2B 18d2ebc532f5820fcb3f3a2e96a834a06a0f2adf4c14e17a1aa2d7aabc360f6180af2bf2151aac5b4eb33e38aade36e38b5894afbfd73ffa79e74bc45c085cbf SHA512 0fdb4385a0d842dccacc60c9b48b8720f00185bb4b6a5b30b88454a1f08e6ff7ead8fc392f406d2d2aff8b1b901caaa950a011b674d83e354dda4a01ac39ab1c
+EBUILD diffoscope-129.ebuild 1881 BLAKE2B eee2bcfe510e10fc647c807de67e8075df0854e288d1b4de8f3072442f34520446e6d0fc81c74ee1c9feb9122ceb33ed1511249c92f064ea9e3efa8e91cdbec4 SHA512 d052c86d59da7d9bd161cca0c4c571c9d093edda02809a2a5639c0e84aaf64a8ca4737bcb5744f7f7155f4437b20c266e90a110e5a00191654d68aaee0ca24dc
EBUILD diffoscope-87.ebuild 1835 BLAKE2B 7e11544ca6290e664e2f243640e70a483ae5aa86ed12b1904c56e46ecb3bfccdf6351e8460df5287006f6ca0c76ed6892bbe8b7804e863f3cc6f592319e4562d SHA512 58ab6f85b61caf31261ede9f807c6bc55a663a3d6582c1f73458b52d8c81bc1009ca8d4966222e2539fce78c0379fe05b938f6f362548b8e5e5f0b785343a1ca
EBUILD diffoscope-88.ebuild 1884 BLAKE2B dbd6e3783941065ecd855b677b58ae2235cc90f631d9b0d7d415603b730513d32b46da275c3d442990d0b660c5f55761b028170db82737067fec6e4ce6c2a7e4 SHA512 382393caf25441d14a073376273c18691207e4dc3913c736998bac413d5ad1b86bd7843a9030b7bf9d4d78752f538050f95a25887acffc809a07657f116524e4
MISC metadata.xml 2078 BLAKE2B 06fb9631030fb0f6d9a482c998238884bb2094751d7f99fb424e5c4f78f97c731eed98b783b14d0215224f786186e5a536e3775a5b7f7b6d980cd468ec243cdb SHA512 69afd9a3ba85d3a6ad92a64811b76708700f0790bff588762a92ad178da94690a940c939de09ca1719fa47ef5c85f10988debda26abef283b9ab01941b3232fc
diff --git a/dev-util/diffoscope/diffoscope-129.ebuild b/dev-util/diffoscope/diffoscope-129.ebuild
new file mode 100644
index 000000000000..34ccce9cfac0
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-129.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg gzip haskell hex imagemagick iso java llvm
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar tcpdump xz zip"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ gzip? ( app-arch/gzip )
+ haskell? ( dev-lang/ghc )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( virtual/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ xz? ( app-arch/xz-utils )
+ zip? ( app-arch/unzip )"