summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-util/diffoscope
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest6
-rw-r--r--dev-util/diffoscope/diffoscope-146.ebuild (renamed from dev-util/diffoscope/diffoscope-145.ebuild)0
-rw-r--r--dev-util/diffoscope/diffoscope-147.ebuild71
3 files changed, 75 insertions, 2 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 78c0a7245945..6ba0ce6f323a 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,3 +1,5 @@
-DIST diffoscope-145.tar.gz 1570621 BLAKE2B f40ecde3e5392559c62c3e9c4dc37b1255f8db22e0a21fb2228995d9da8e977fd88fbbdd44a4cbdb75762cc56afba801de2f235a9f348fcdc4f3e77c7c665ceb SHA512 400d40b7a6a00b246630d8ab251dc9fc1a1c0ca117102ef13f793cff63dfa551f4b77081f6061c47bf87d8de65fef406d34a8b63692c5b129526132c01b1b082
-EBUILD diffoscope-145.ebuild 2161 BLAKE2B 9ef4a812c5fec5a923b0b796814052c00842cd36a447832fe65aed32c341454538ddccce2baac0b038d8bf02cbed98a2023eeba33e8a7868f34a882331098c34 SHA512 e508fee8307b2e634ec33877124156fcb8afd43307747b1f61e18ecfeaac00c1140c1906ef87015f3b76f70ac5679c28fed47539e52ce0adc29c6257ad6deacb
+DIST diffoscope-146.tar.gz 1570347 BLAKE2B c94be83c8c1de97c054b10dccb66f9f1df9dd1a84b0491137a61b5c1d539947332a2629b4e752ff338d4797cb1eb655a7244b17abcaf7f1dc856b3bd4303810e SHA512 50c6ae4241f599e3fbe0a99bc9654a739d2c97314c2e04d0f1c225c0e90fab1ea6e1e2f39ab1f14efb06d2e29683a8a76419b1dc044f7f2f11db1329a831a30f
+DIST diffoscope-147.tar.gz 1570418 BLAKE2B 845d4c5f59d479237b614962601493b06f07955d5aa4469e47e4e2619587c32b6daad81a528fd0a9db6c492cb7a4c8366edf69aec460bc994e1b38fc01cc5ad9 SHA512 4017bbf3164febfa7ec628ad34a7ee5aa3cde6528878f0197ce0fab82bbf8067f0f9e7d51ed569e0d69c8a82bd3b044d9dfcbc3c4f4a6195ac9886594796ec61
+EBUILD diffoscope-146.ebuild 2161 BLAKE2B 9ef4a812c5fec5a923b0b796814052c00842cd36a447832fe65aed32c341454538ddccce2baac0b038d8bf02cbed98a2023eeba33e8a7868f34a882331098c34 SHA512 e508fee8307b2e634ec33877124156fcb8afd43307747b1f61e18ecfeaac00c1140c1906ef87015f3b76f70ac5679c28fed47539e52ce0adc29c6257ad6deacb
+EBUILD diffoscope-147.ebuild 2161 BLAKE2B 9ef4a812c5fec5a923b0b796814052c00842cd36a447832fe65aed32c341454538ddccce2baac0b038d8bf02cbed98a2023eeba33e8a7868f34a882331098c34 SHA512 e508fee8307b2e634ec33877124156fcb8afd43307747b1f61e18ecfeaac00c1140c1906ef87015f3b76f70ac5679c28fed47539e52ce0adc29c6257ad6deacb
MISC metadata.xml 2137 BLAKE2B 6ff55f85ebf3f769c10c3e17a69900918abe142e491b7b8460bed8fe6a036763a743324bf1a10e7a3772761b38c9632ff1352e9c6677ef691f81acc29dc321e9 SHA512 e782e12dc91d86612768a2e0c498f54a9728691a76008ee1e6cdbc4d8719c2593344f6c37786982abb0de7b85d743d7614652a2e8c9cd9fef053c3a32e1e484c
diff --git a/dev-util/diffoscope/diffoscope-145.ebuild b/dev-util/diffoscope/diffoscope-146.ebuild
index 63058ee2f20a..63058ee2f20a 100644
--- a/dev-util/diffoscope/diffoscope-145.ebuild
+++ b/dev-util/diffoscope/diffoscope-146.ebuild
diff --git a/dev-util/diffoscope/diffoscope-147.ebuild b/dev-util/diffoscope/diffoscope-147.ebuild
new file mode 100644
index 000000000000..63058ee2f20a
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-147.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg gzip haskell hdf5 hex imagemagick iso java llvm
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar tcpdump xz zip zstd"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ gzip? ( app-arch/gzip )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( virtual/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ xz? ( app-arch/xz-utils )
+ zip? ( app-arch/unzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"