summaryrefslogtreecommitdiff
path: root/dev-util/diffball/diffball-1.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-util/diffball/diffball-1.0.1-r2.ebuild
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-util/diffball/diffball-1.0.1-r2.ebuild')
-rw-r--r--dev-util/diffball/diffball-1.0.1-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/diffball/diffball-1.0.1-r2.ebuild b/dev-util/diffball/diffball-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..ab5bc9dfe7b4
--- /dev/null
+++ b/dev-util/diffball/diffball-1.0.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://github.com/zmedico/diffball"
+SRC_URI="https://github.com/zmedico/diffball/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/zmedico/diffball/pull/1.patch -> ${P}-bug_543310_stack_buffer_overflows.patch
+ https://github.com/zmedico/diffball/pull/2.patch -> ${P}-bug_708736_cseek_xz_reset_avail_in_out.patch"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2
+ app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# Invalid RESTRICT for source package. Investigate.
+RESTRICT="strip"
+
+PATCHES=(
+ "${DISTDIR}/${P}-bug_543310_stack_buffer_overflows.patch"
+ "${DISTDIR}/${P}-bug_708736_cseek_xz_reset_avail_in_out.patch"
+)
+
+src_prepare() {
+ # fix bug 548316 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static $(use_enable debug asserts)
+}