summaryrefslogtreecommitdiff
path: root/dev-util/cyclo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/cyclo
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/cyclo')
-rw-r--r--dev-util/cyclo/Manifest4
-rw-r--r--dev-util/cyclo/cyclo-2.1.0.ebuild48
-rw-r--r--dev-util/cyclo/metadata.xml15
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/cyclo/Manifest b/dev-util/cyclo/Manifest
new file mode 100644
index 000000000000..d58a6c0fc0fd
--- /dev/null
+++ b/dev-util/cyclo/Manifest
@@ -0,0 +1,4 @@
+DIST cyclo-2.1.0.tar.gz 27120 SHA256 b8753c149e298d3683add4aec834fb4a4b748636b7bfd9a79a2548e6b81e2045 SHA512 19cf4116e55ba3dff6e49536fed7e5a8da4cc2b691874b5356e67763652785b3f349cb309629e9aca66be15f1c4632ece8bcd5cc3b69373a5a7923eab8058382 WHIRLPOOL c805174fffb6d1cc9a5d9d6c6f7a460699a48347ce5ac5eae0f55cbc3b55b5305624f8e29ecd9f9889242557bd362bfcb99feda8661fd26e13250be590d11132
+EBUILD cyclo-2.1.0.ebuild 1045 SHA256 4dc86002c8f601ac6b691374b96fa92371e4f953784cc7274c108826eaf79c05 SHA512 471e26f0e828075db53f14b093150e84af1897a468893d1d6d480f16c9bfa961769b7b30978dca58cc3a863e7aa42fc868c49a7bc3ebc5e6c90f68b5459ef718 WHIRLPOOL 2c888b5e111a11b47da015ceb5ef71a8e921480d96876f36b4cdaf3b76df3840c3e1f325fccd22eb671c69114cc44b9625aa22e4339166882a9543fb0aec82ab
+MISC ChangeLog 1334 SHA256 b159d8e6278b403f31e822a498a54192255d09a95712a63afe969a597835a893 SHA512 2657cfac634c622ae42671846bd7047992e1ab78871be42d25e387df158cab8826ced532592216fa00724a998d3bdb7cac47b94a6aadabc70155a90096599944 WHIRLPOOL b5244362fbde562ff6bb9a1ab0812f81f67f74fb0c52365792fd048c465ece46333b33f5933b427a7dfeef046d85c11a14cf0461a14f3f1330fd0cef301633c0
+MISC metadata.xml 426 SHA256 568605b1e07330970159443ce3ca815987e82366d1823e18e8a5a4f46b9e16dd SHA512 fdfe058a00119d456af23e314426ead9fa02903e9c3b91c9176cd2dd611b46e876e8c3787a9d6937682b6b3d65eb5f688348f7cbffd9197a666042f02bacb6ac WHIRLPOOL e543e968dd2467427f88f30052c0e40d8a8cd1a4d9d751a9ea2b4526fd07bd9b5a8a02b94d1f86f7be0b62063be018fd238fb3558ec0e4fbd89ff9485a2add7b
diff --git a/dev-util/cyclo/cyclo-2.1.0.ebuild b/dev-util/cyclo/cyclo-2.1.0.ebuild
new file mode 100644
index 000000000000..7f3353155ed8
--- /dev/null
+++ b/dev-util/cyclo/cyclo-2.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Computes cyclomatic complexity metrics on C source code."
+HOMEPAGE="https://github.com/sarnold/cyclo"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/cyclo.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="debug"
+
+DEPEND="sys-devel/flex"
+
+src_compile() {
+ local my_opts
+ my_opts="CC=$(tc-getCC) CXX=$(tc-getCXX)"
+
+ if ! use debug ; then
+ DBG="" emake ${my_opts} || die "make failed"
+ else
+ export STRIP_MASK="*/bin/*"
+ if [ -n "${DEBUG}" ] ; then
+ DBG="${DEBUG}" emake ${my_opts} \
+ || die "make debug failed"
+ else
+ emake ${my_opts} || die "make debug failed"
+ fi
+ fi
+}
+
+src_test() {
+ make -f Makefile.test test
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${ED}" install
+}
diff --git a/dev-util/cyclo/metadata.xml b/dev-util/cyclo/metadata.xml
new file mode 100644
index 000000000000..aefcf1b14858
--- /dev/null
+++ b/dev-util/cyclo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+</maintainer>
+<maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">sarnold/cyclo</remote-id>
+</upstream>
+</pkgmetadata>