summaryrefslogtreecommitdiff
path: root/dev-util/cyclo/cyclo-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/cyclo/cyclo-2.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/cyclo/cyclo-2.1.0.ebuild')
-rw-r--r--dev-util/cyclo/cyclo-2.1.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/cyclo/cyclo-2.1.0.ebuild b/dev-util/cyclo/cyclo-2.1.0.ebuild
new file mode 100644
index 000000000000..7f3353155ed8
--- /dev/null
+++ b/dev-util/cyclo/cyclo-2.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Computes cyclomatic complexity metrics on C source code."
+HOMEPAGE="https://github.com/sarnold/cyclo"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/cyclo.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="debug"
+
+DEPEND="sys-devel/flex"
+
+src_compile() {
+ local my_opts
+ my_opts="CC=$(tc-getCC) CXX=$(tc-getCXX)"
+
+ if ! use debug ; then
+ DBG="" emake ${my_opts} || die "make failed"
+ else
+ export STRIP_MASK="*/bin/*"
+ if [ -n "${DEBUG}" ] ; then
+ DBG="${DEBUG}" emake ${my_opts} \
+ || die "make debug failed"
+ else
+ emake ${my_opts} || die "make debug failed"
+ fi
+ fi
+}
+
+src_test() {
+ make -f Makefile.test test
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${ED}" install
+}