summaryrefslogtreecommitdiff
path: root/dev-util/csup/files/csup-20060318-respectflags.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-util/csup/files/csup-20060318-respectflags.patch
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-util/csup/files/csup-20060318-respectflags.patch')
-rw-r--r--dev-util/csup/files/csup-20060318-respectflags.patch38
1 files changed, 23 insertions, 15 deletions
diff --git a/dev-util/csup/files/csup-20060318-respectflags.patch b/dev-util/csup/files/csup-20060318-respectflags.patch
index c95a974c75ed..541622df5777 100644
--- a/dev-util/csup/files/csup-20060318-respectflags.patch
+++ b/dev-util/csup/files/csup-20060318-respectflags.patch
@@ -1,22 +1,22 @@
-Index: csup/GNUmakefile
-===================================================================
---- csup.orig/GNUmakefile
-+++ csup/GNUmakefile
-@@ -21,7 +21,7 @@ WARNS= -Wall -W -Wno-unused-parameter -W
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -21,22 +21,22 @@
-Wcast-align -Wunused-parameter -Wchar-subscripts -Winline \
-Wnested-externs -Wredundant-decls -Wno-format-y2k
-CFLAGS+= -g -O -pipe -DNDEBUG -I$(PREFIX)/include
-+CFLAGS+= -I$(PREFIX)/include
++CPPFLAGS+= -DNDEBUG -I$(PREFIX)/include
ifeq ($(UNAME), Linux)
- CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+- CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++ CPPFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
endif
-@@ -29,14 +29,14 @@ ifeq ($(UNAME), Darwin)
- CFLAGS+= -DHAVE_FFLAGS
+ ifeq ($(UNAME), Darwin)
+- CFLAGS+= -DHAVE_FFLAGS
++ CPPFLAGS+= -DHAVE_FFLAGS
endif
CFLAGS+= $(WARNS)
-LDFLAGS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
-+LIBS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
++LIBS= -lcrypto -lz -lpthread
.PHONY: all clean install
@@ -28,11 +28,19 @@ Index: csup/GNUmakefile
config.c: parse.h
-Index: csup/Makefile
-===================================================================
---- csup.orig/Makefile
-+++ csup/Makefile
-@@ -11,7 +11,7 @@ SRCS= attrstack.c config.c detailer.c di
+@@ -49,9 +49,6 @@
+ clean:
+ rm -f csup $(OBJS) parse.c parse.h token.c csup.1.gz
+
+-%.o: %.c
+- $(CC) $(CFLAGS) -c -o $@ $<
+-
+ %.c: %.y
+ $(YACC) -d -o $@ $<
+
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@
globtree.c idcache.c keyword.c lister.c main.c misc.c mux.c parse.y \
pathcomp.c proto.c status.c stream.c threads.c token.l updater.c