summaryrefslogtreecommitdiff
path: root/dev-util/crash/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/crash/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/crash/files')
-rw-r--r--dev-util/crash/files/crash-5.1.1-install-fix.patch12
-rw-r--r--dev-util/crash/files/crash-7.1.4-sysmacros.patch27
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/crash/files/crash-5.1.1-install-fix.patch b/dev-util/crash/files/crash-5.1.1-install-fix.patch
new file mode 100644
index 000000000000..98b86759361d
--- /dev/null
+++ b/dev-util/crash/files/crash-5.1.1-install-fix.patch
@@ -0,0 +1,12 @@
+diff -Nur crash-5.1.1/Makefile crash-5.1.1-fixes//Makefile
+--- crash-5.1.1/Makefile 2010-12-23 12:59:44.000000000 -0600
++++ crash-5.1.1-fixes//Makefile 2011-01-26 13:17:11.000000000 -0600
+@@ -322,7 +322,7 @@
+ cc -c ${CRASH_CFLAGS} build_data.c ${WARNING_OPTIONS} ${WARNING_ERROR}
+
+ install:
+- /usr/bin/install ${PROGRAM} ${INSTALLDIR}
++ /usr/bin/install -D ${PROGRAM} ${INSTALLDIR}/${PROGRAM}
+ # /usr/bin/install ${PROGRAM}d ${INSTALLDIR}
+
+ unconfig: make_configure
diff --git a/dev-util/crash/files/crash-7.1.4-sysmacros.patch b/dev-util/crash/files/crash-7.1.4-sysmacros.patch
new file mode 100644
index 000000000000..6e6d40cca4d2
--- /dev/null
+++ b/dev-util/crash/files/crash-7.1.4-sysmacros.patch
@@ -0,0 +1,27 @@
+From f22dabb45448e5a8d2df85703fd72b0f83fe7eda Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 21 Apr 2016 00:44:04 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor/makedev
+
+These funcs are defined in the sys/sysmacros.h header, not sys/types.h.
+Linux C libraries are updating to drop the implicit include, so we need
+to include it explicitly.
+---
+ filesys.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/filesys.c b/filesys.c
+index 2ed25f4..9b59998 100644
+--- a/filesys.c
++++ b/filesys.c
+@@ -16,6 +16,7 @@
+ */
+
+ #include "defs.h"
++#include <sys/sysmacros.h>
+ #include <linux/major.h>
+ #include <regex.h>
+ #include <sys/utsname.h>
+--
+2.7.4
+