summaryrefslogtreecommitdiff
path: root/dev-util/crash/crash-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-05 13:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-05 13:06:03 +0000
commitf61d8811e916303cabe9fafdefbe188ba9b500d5 (patch)
tree2af9236d3e678dca4d443b94bfc1b88aec45c669 /dev-util/crash/crash-9999.ebuild
parent66a7d60eb8beba754ba79c2752cbf70fcf741b0b (diff)
gentoo auto-resync : 05:03:2024 - 13:06:02
Diffstat (limited to 'dev-util/crash/crash-9999.ebuild')
-rw-r--r--dev-util/crash/crash-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-util/crash/crash-9999.ebuild b/dev-util/crash/crash-9999.ebuild
index e5ef7a7ea356..34c8d94dfb93 100644
--- a/dev-util/crash/crash-9999.ebuild
+++ b/dev-util/crash/crash-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
GDB_VERSION=10.2
if [[ ${PV} == "9999" ]] ; then
@@ -33,6 +33,13 @@ src_prepare() {
ln -s "${DISTDIR}"/gdb-10.2.tar.gz . || die
}
+src_configure() {
+ # bug #858344
+ filter-lto
+
+ default
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \