summaryrefslogtreecommitdiff
path: root/dev-util/crash/crash-7.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-util/crash/crash-7.3.1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-util/crash/crash-7.3.1.ebuild')
-rw-r--r--dev-util/crash/crash-7.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/crash/crash-7.3.1.ebuild b/dev-util/crash/crash-7.3.1.ebuild
new file mode 100644
index 000000000000..24b0d3f6115c
--- /dev/null
+++ b/dev-util/crash/crash-7.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/crash-utility/crash.git"
+ SRC_URI="http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/crash-utility/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ mirror://gnu/gdb/gdb-7.6.tar.gz"
+ KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
+fi
+
+DESCRIPTION="Red Hat crash utility; used for analyzing kernel core dumps"
+HOMEPAGE="https://crash-utility.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# there is no "make test" target, but there is a test.c so the automatic
+# make rules catch it and tests fail
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e "s|ar -rs|\${AR} -rs|g" Makefile || die
+ ln -s "${DISTDIR}"/gdb-7.6.tar.gz . || die
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}