summaryrefslogtreecommitdiff
path: root/dev-util/crash/crash-7.2.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-util/crash/crash-7.2.8-r1.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-util/crash/crash-7.2.8-r1.ebuild')
-rw-r--r--dev-util/crash/crash-7.2.8-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/crash/crash-7.2.8-r1.ebuild b/dev-util/crash/crash-7.2.8-r1.ebuild
new file mode 100644
index 000000000000..45bbff515903
--- /dev/null
+++ b/dev-util/crash/crash-7.2.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Red Hat crash utility; used for analyzing kernel core dumps"
+HOMEPAGE="https://people.redhat.com/anderson/"
+SRC_URI="https://people.redhat.com/anderson/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
+IUSE=""
+# there is no "make test" target, but there is a test.c so the automatic
+# make rules catch it and tests fail
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e "s|ar -rs|\${AR} -rs|g" Makefile || die
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}