summaryrefslogtreecommitdiff
path: root/dev-util/cpptest/cpptest-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-util/cpptest/cpptest-2.0.0.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-util/cpptest/cpptest-2.0.0.ebuild')
-rw-r--r--dev-util/cpptest/cpptest-2.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/cpptest/cpptest-2.0.0.ebuild b/dev-util/cpptest/cpptest-2.0.0.ebuild
new file mode 100644
index 000000000000..8369dad2328c
--- /dev/null
+++ b/dev-util/cpptest/cpptest-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="https://github.com/cpptest/cpptest"
+SRC_URI="https://github.com/cpptest/cpptest/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1" # for soversion 1.x.x
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="!dev-util/cpptest:0"
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}