summaryrefslogtreecommitdiff
path: root/dev-util/cpptest/cpptest-2.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-util/cpptest/cpptest-2.0.0-r1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-util/cpptest/cpptest-2.0.0-r1.ebuild')
-rw-r--r--dev-util/cpptest/cpptest-2.0.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/cpptest/cpptest-2.0.0-r1.ebuild b/dev-util/cpptest/cpptest-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..044ea47a4a8a
--- /dev/null
+++ b/dev-util/cpptest/cpptest-2.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="https://github.com/cpptest/cpptest"
+SRC_URI="https://github.com/cpptest/cpptest/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1" # for soversion 1.x.x
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="!dev-util/cpptest:0"
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+ econf $(use_enable doc) $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}