summaryrefslogtreecommitdiff
path: root/dev-util/cpptest/cpptest-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/cpptest/cpptest-1.1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/cpptest/cpptest-1.1.2.ebuild')
-rw-r--r--dev-util/cpptest/cpptest-1.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/cpptest/cpptest-1.1.2.ebuild b/dev-util/cpptest/cpptest-1.1.2.ebuild
new file mode 100644
index 000000000000..4dce91f1de21
--- /dev/null
+++ b/dev-util/cpptest/cpptest-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="http://cpptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}