summaryrefslogtreecommitdiff
path: root/dev-util/cppcheck/cppcheck-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-util/cppcheck/cppcheck-9999.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-util/cppcheck/cppcheck-9999.ebuild')
-rw-r--r--dev-util/cppcheck/cppcheck-9999.ebuild40
1 files changed, 23 insertions, 17 deletions
diff --git a/dev-util/cppcheck/cppcheck-9999.ebuild b/dev-util/cppcheck/cppcheck-9999.ebuild
index 38d6d57ecc24..9d9977873aa9 100644
--- a/dev-util/cppcheck/cppcheck-9999.ebuild
+++ b/dev-util/cppcheck/cppcheck-9999.ebuild
@@ -1,15 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 flag-o-matic qmake-utils toolchain-funcs git-r3
+inherit distutils-r1 git-r3 qmake-utils toolchain-funcs
DESCRIPTION="Static analyzer of C/C++ code"
HOMEPAGE="http://cppcheck.sourceforge.net"
-EGIT_REPO_URI="https://github.com/danmar/cppcheck.git"
+EGIT_REPO_URI="https://github.com/danmar/cppcheck"
LICENSE="GPL-3+"
SLOT="0"
@@ -31,39 +29,47 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
virtual/pkgconfig
"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.75-tinyxml2.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.75-tinyxml2.patch
+ "${FILESDIR}"/${PN}-1.85-ldflags.patch
+)
src_prepare() {
default
- append-cxxflags -std=c++0x
- # Drop bundled libs, patch Makefile generator and re-run it
rm -r externals/tinyxml || die
- tc-export CXX
- emake dmake
- ./dmake || die
}
src_configure() {
+ tc-export CXX PKG_CONFIG
+ export LIBS="$(${PKG_CONFIG} --libs tinyxml2)"
+
+ emake dmake
+ ./dmake || die
+
if use pcre ; then
sed -e '/HAVE_RULES=/s:=no:=yes:' \
-i Makefile || die
fi
+
+ if use qt5 ; then
+ pushd gui || die
+ eqmake5
+ popd || die
+ fi
}
src_compile() {
- export LIBS="$(pkg-config --libs tinyxml2)"
emake ${PN} man \
- CFGDIR="${EROOT}usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
+ CFGDIR="${EROOT}/usr/share/${PN}/cfg" \
+ DB2MAN="${EROOT}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
if use qt5 ; then
pushd gui || die
- eqmake5
emake
popd || die
fi
+
if use htmlreport ; then
pushd htmlreport || die
distutils-r1_src_compile