summaryrefslogtreecommitdiff
path: root/dev-util/confix/files/2.3.0
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/confix/files/2.3.0
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/confix/files/2.3.0')
-rw-r--r--dev-util/confix/files/2.3.0/exeext.patch20
-rw-r--r--dev-util/confix/files/2.3.0/ext-ac-archive.patch35
-rw-r--r--dev-util/confix/files/2.3.0/local-libs-first.patch39
-rw-r--r--dev-util/confix/files/2.3.0/new-automake.patch12
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-util/confix/files/2.3.0/exeext.patch b/dev-util/confix/files/2.3.0/exeext.patch
new file mode 100644
index 000000000000..98576f5c9f8b
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/exeext.patch
@@ -0,0 +1,20 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/makefile_am.py confix-9999/libconfix/plugins/automake/makefile_am.py
+--- confix-9999.orig/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:20:42.106291175 +0100
++++ confix-9999/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:23:39.562354663 +0100
+@@ -472,7 +472,15 @@
+
+ # register automatic tests and set their environment
+
+- tests = self.dir_primary('check', 'PROGRAMS') + \
++ test_tmp = self.dir_primary('check', 'PROGRAMS')
++ count = 0
++ for prog in test_tmp:
++ prog += "$(EXEEXT)"
++ test_tmp[count] = prog
++ count += 1
++ pass
++
++ tests = test_tmp + \
+ self.dir_primary('check', 'SCRIPTS')
+ if len(tests):
+ lines.extend(makefile.List(name='TESTS', values=tests, mitigate=True).lines())
diff --git a/dev-util/confix/files/2.3.0/ext-ac-archive.patch b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
new file mode 100644
index 000000000000..32122c95bfe2
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
@@ -0,0 +1,35 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/bootstrap.py confix-9999/libconfix/plugins/automake/bootstrap.py
+--- confix-9999.orig/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:25:27.962172020 +0100
++++ confix-9999/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:27:14.780605001 +0100
+@@ -16,7 +16,7 @@
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ # USA
+
+-import autoconf_archive
++#import autoconf_archive
+ import kde_hack
+
+ from libconfix.core.utils.error import Error
+@@ -29,7 +29,7 @@
+
+ def bootstrap(packageroot, use_kde_hack, argv0, path=None):
+ aclocal_incdirs = []
+- aclocal_incdirs.append(autoconf_archive.include_path(argv0))
++ #aclocal_incdirs.append(autoconf_archive.include_path(argv0))
+
+ # if package's configure.ac looks like using libtool, then we
+ # assume that the package must be libtoolize'd.
+diff -ru confix-9999.orig/setup.py confix-9999/setup.py
+--- confix-9999.orig/setup.py 2009-10-30 13:25:27.965360137 +0100
++++ confix-9999/setup.py 2009-10-30 13:26:47.822129311 +0100
+@@ -41,8 +41,8 @@
+ return result
+
+ datafiles = []
+-datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
+-datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
+
+ # scripts to put in the auxdir.
+ datafiles.extend([('share/confix/kde-hack',
diff --git a/dev-util/confix/files/2.3.0/local-libs-first.patch b/dev-util/confix/files/2.3.0/local-libs-first.patch
new file mode 100644
index 000000000000..29d4a7a1cc9d
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/local-libs-first.patch
@@ -0,0 +1,39 @@
+With libtool, link local libraries with /path/to/libfile.la instead of libpath,
+to avoid encoding local libpath into installed la-file.
+These also have to be linked first, to avoid finding already installed
+libraries of previous versions during libtool-relink.
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py Confix-2.3.0/libconfix/plugins/automake/c/out_c.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py 2010-07-06 12:55:59.286540943 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/c/out_c.py 2010-07-06 13:01:23.574428852 +0200
+@@ -411,6 +411,8 @@
+ """
+ assert isinstance(linked_builder, LinkedBuilder)
+
++ local_paths = []
++ local_libraries = []
+ native_paths = []
+ native_libraries = []
+ external_linkline = []
+@@ -424,8 +426,11 @@
+
+ for bi in native_libs_to_use:
+ if isinstance(bi, BuildInfo_CLibrary_NativeLocal):
+- native_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
+- native_libraries.append('-l'+bi.basename())
++ if self.__use_libtool:
++ local_libraries.append('/'.join(['$(top_builddir)']+bi.dir()+['lib'+bi.basename()+'.la']))
++ else:
++ local_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
++ local_libraries.append('-l'+bi.basename())
+ continue
+ if isinstance(bi, BuildInfo_CLibrary_NativeInstalled):
+ using_installed_library = True
+@@ -447,7 +452,7 @@
+ external_linkline.extend(elem)
+ pass
+
+- return native_paths + native_libraries + external_linkline
++ return local_paths + local_libraries + native_paths + native_libraries + external_linkline
+
+ def external_libpath(self):
+ """ For unit tests only. """
diff --git a/dev-util/confix/files/2.3.0/new-automake.patch b/dev-util/confix/files/2.3.0/new-automake.patch
new file mode 100644
index 000000000000..d6f24a4cae81
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/new-automake.patch
@@ -0,0 +1,12 @@
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py Confix-2.3.0/libconfix/plugins/automake/out_automake.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py 2010-07-12 13:15:49.254867387 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/out_automake.py 2010-07-12 13:17:29.755908602 +0200
+@@ -170,7 +170,7 @@
+
+
+ # our minimum required automake version is 1.9
+- self.makefile_am().add_automake_options('1.9')
++ # self.makefile_am().add_automake_options('1.9')
+
+
+ # enable dist'ing in the following formats