summaryrefslogtreecommitdiff
path: root/dev-util/colm/files/colm-0.14.7-drop-julia-check.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-util/colm/files/colm-0.14.7-drop-julia-check.patch
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-util/colm/files/colm-0.14.7-drop-julia-check.patch')
-rw-r--r--dev-util/colm/files/colm-0.14.7-drop-julia-check.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/colm/files/colm-0.14.7-drop-julia-check.patch b/dev-util/colm/files/colm-0.14.7-drop-julia-check.patch
new file mode 100644
index 000000000000..fc027927d298
--- /dev/null
+++ b/dev-util/colm/files/colm-0.14.7-drop-julia-check.patch
@@ -0,0 +1,45 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -284,41 +284,7 @@ AC_PATH_PROG([OCAML_BIN], [ocaml])
+ AC_PATH_PROG([RUST_BIN], [rustc])
+ AC_PATH_PROG([JULIA_BIN], [julia])
+
+-dnl
+-dnl Julia requires a large virtual address space. On systems where this is
+-dnl limited by ulimit, julia will fail to run.
+-dnl
+-
+-if test "x$JULIA_BIN" != x; then
+- echo 'println( "can run julia programs" );' > conftest.jl
+- AC_MSG_CHECKING([checking if julia is able to run programs ... ])
+- if sh -c "$JULIA_BIN conftest.jl" >>config.log 2>&1; then
+- AC_MSG_RESULT([yes])
+- else
+- AC_MSG_RESULT([no])
+- JULIA_BIN=""
+- fi
+- rm -f conftest.jl
+-fi
+-
+-dnl We can run julia, now make sure we have 1.0
+-if test "x$JULIA_BIN" != x; then
+- AC_MSG_CHECKING([checking if julia is version 1.0 or later ... ])
+-
+- dnl We assume the form "julia version X.X.X"
+- dnl 1. everything before the version number.
+- dnl 2. Remove trailing version.
+- dnl 3. Verify it is plain number greater than 1.
+- dnl Any failure comes out as empty string. Note the sed command is wrapped
+- dnl in [] so autotools do not interpret anything in it.
+- JULIA1="`$JULIA_BIN -v | sed ['s/[A-Za-z ]\+//g; s/\.[0-9\.]*//; /^[1-9][0-9]*/!d;']`"
+- if test "x$JULIA1" != x; then
+- AC_MSG_RESULT([yes])
+- else
+- AC_MSG_RESULT([no])
+- JULIA_BIN=""
+- fi
+-fi
++JULIA_BIN=""
+
+ AC_PATH_PROG([GNUSTEP_CONFIG], [gnustep-config])
+