summaryrefslogtreecommitdiff
path: root/dev-util/coccigrep/coccigrep-1.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/coccigrep/coccigrep-1.13.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/coccigrep/coccigrep-1.13.ebuild')
-rw-r--r--dev-util/coccigrep/coccigrep-1.13.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-util/coccigrep/coccigrep-1.13.ebuild b/dev-util/coccigrep/coccigrep-1.13.ebuild
deleted file mode 100644
index f56d4bacedc9..000000000000
--- a/dev-util/coccigrep/coccigrep-1.13.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="A semantic grep for the C language"
-HOMEPAGE="http://home.regit.org/software/coccigrep/"
-SRC_URI="https://github.com/regit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs vim"
-
-RDEPEND="dev-util/coccinelle[python]
- emacs? ( virtual/emacs )
- vim? ( || ( app-editors/vim app-editors/gvim ) )"
-DEPEND="doc? ( dev-python/sphinx )
- emacs? ( virtual/emacs )"
-
-SITEFILE="50${PN}-gentoo.el"
-
-python_compile_all() {
- use doc && emake -C doc html
-
- if use emacs ; then
- elisp-compile editors/*.el || die
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS="doc/_build/html/."
- distutils-r1_python_install_all
-
- doman ${PN}.1
-
- if use emacs ; then
- elisp-install ${PN} editors/*.{el,elc} || die
- elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
- fi
-
- if use vim ; then
- insinto /usr/share/vim/vimfiles/plugin
- doins editors/cocci-grep.vim
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- einfo "Syntax highlighting is supported through dev-python/pygments."
- einfo "Install it if you want colorized output formats."
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}