summaryrefslogtreecommitdiff
path: root/dev-util/cmocka/cmocka-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-util/cmocka/cmocka-1.1.1.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-util/cmocka/cmocka-1.1.1.ebuild')
-rw-r--r--dev-util/cmocka/cmocka-1.1.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-util/cmocka/cmocka-1.1.1.ebuild b/dev-util/cmocka/cmocka-1.1.1.ebuild
deleted file mode 100644
index 82d5e18c4b88..000000000000
--- a/dev-util/cmocka/cmocka-1.1.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib
-
-DESCRIPTION="A unit testing framework for C"
-HOMEPAGE="https://cmocka.org/"
-SRC_URI="https://cmocka.org/files/1.1/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc static-libs test"
-
-DEPEND="
- doc? ( app-doc/doxygen[latex] )
-"
-RDEPEND=""
-
-DOCS=( AUTHORS ChangeLog README )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DWITH_STATIC_LIB=$(usex static-libs)
- -DUNIT_TESTING=$(usex test)
- $(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
- || echo -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON)
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use doc; then
- pushd doc || die
- doxygen Doxyfile || die
- rm -f html/*.md5 latex/*.md5 latex/Manifest man/man3/_* || die
- dodoc -r html/
- dodoc -r latex/
- doman man/man3/*.3
- popd || die
- fi
-
- cmake-utils_src_install
-}