summaryrefslogtreecommitdiff
path: root/dev-util/cmake/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-util/cmake/files
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-util/cmake/files')
-rw-r--r--dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch b/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch
new file mode 100644
index 000000000000..3a4c4352c6ff
--- /dev/null
+++ b/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch
@@ -0,0 +1,21 @@
+--- cmake-3.11.0-rc1/Source/CMakeLists.txt
++++ cmake-3.11.0-rc1/Source/CMakeLists.txt
+@@ -765,6 +765,7 @@
+ ${CMAKE_LIBUV_LIBRARIES}
+ ${CMAKE_LIBRHASH_LIBRARIES}
+ ${CMake_KWIML_LIBRARIES}
++ pthread
+ )
+
+ if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR MATCHES "sparc")
+--- cmake-3.11.0-rc1/Tests/CMakeLib/CMakeLists.txt
++++ cmake-3.11.0-rc1/Tests/CMakeLib/CMakeLists.txt
+@@ -30,7 +30,7 @@
+
+ create_test_sourcelist(CMakeLib_TEST_SRCS CMakeLibTests.cxx ${CMakeLib_TESTS})
+ add_executable(CMakeLibTests ${CMakeLib_TEST_SRCS})
+-target_link_libraries(CMakeLibTests CMakeLib)
++target_link_libraries(CMakeLibTests CMakeLib pthread)
+
+ set_property(TARGET CMakeLibTests PROPERTY C_CLANG_TIDY "")
+ set_property(TARGET CMakeLibTests PROPERTY CXX_CLANG_TIDY "")