summaryrefslogtreecommitdiff
path: root/dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild')
-rw-r--r--dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild b/dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild
new file mode 100644
index 000000000000..68276acbf49a
--- /dev/null
+++ b/dev-util/chroot-wrapper/chroot-wrapper-0.9.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Wrapper for chroot to set up some bind mounts, namespaces, and control groups"
+HOMEPAGE="https://github.com/chutz/chroot-wrapper"
+SRC_URI="https://github.com/chutz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ sys-apps/util-linux
+ sys-apps/coreutils
+"
+
+CONFIG_CHECK="
+ ~TMPFS
+ ~IPC_NS
+ ~UTS_NS
+"
+
+src_install() {
+ newsbin src/chroot-wrapper chr
+ insinto /etc/chroot-wrapper
+ doins config.bash
+}