summaryrefslogtreecommitdiff
path: root/dev-util/cdecl/cdecl-14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-31 16:05:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-31 16:05:26 +0100
commit569e3558cac0a0ecdc6b80debb515b5ed8515df9 (patch)
treea024cffdfa7c5456f9f9105d77ced3ebf52202b7 /dev-util/cdecl/cdecl-14.0.ebuild
parentf8b05ca448cdc580f580ff86eb8bef367d67c9ae (diff)
gentoo auto-resync : 31:03:2023 - 16:05:25
Diffstat (limited to 'dev-util/cdecl/cdecl-14.0.ebuild')
-rw-r--r--dev-util/cdecl/cdecl-14.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/cdecl/cdecl-14.0.ebuild b/dev-util/cdecl/cdecl-14.0.ebuild
new file mode 100644
index 000000000000..b5e991c3c9b0
--- /dev/null
+++ b/dev-util/cdecl/cdecl-14.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION='Composing and deciphering C (or C++) declarations or casts, aka "gibberish."'
+HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
+SRC_URI="https://github.com/paul-j-lucas/cdecl/releases/download/${P}/${P}.tar.gz -> ${P}.release.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug readline ncurses"
+
+DEPEND="
+ ncurses? ( sys-libs/ncurses:0= )
+ readline? ( sys-libs/readline:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable ncurses term-size) \
+ $(use_enable debug bison-debug) \
+ $(use_enable debug flex-debug)
+}