summaryrefslogtreecommitdiff
path: root/dev-util/ccls/ccls-0.20220729-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 12:20:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 12:20:34 +0000
commit79e2fe7ce5d8192f7ddc9f57d4fb11bd1231f041 (patch)
tree214e48e63c0393badb2c99be0bc323c046ee2a25 /dev-util/ccls/ccls-0.20220729-r1.ebuild
parent30f491533785a455cdfbd05bb57f1f869a8e41bb (diff)
gentoo auto-resync : 10:01:2023 - 12:20:33
Diffstat (limited to 'dev-util/ccls/ccls-0.20220729-r1.ebuild')
-rw-r--r--dev-util/ccls/ccls-0.20220729-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/ccls/ccls-0.20220729-r1.ebuild b/dev-util/ccls/ccls-0.20220729-r1.ebuild
new file mode 100644
index 000000000000..e78d353ba345
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20220729-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ LLVM_MAX_SLOT=15
+else
+ LLVM_MAX_SLOT=15
+fi
+
+inherit cmake llvm ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+# We only depend on Clang because of a quirk in how dependencies work
+# See comment in llvm.eclass docs
+DEPEND="
+ dev-libs/rapidjson
+ <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCCLS_VERSION=${PV}
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ -DCLANG_LINK_CLANG_DYLIB=1
+ )
+ cmake_src_configure
+}