summaryrefslogtreecommitdiff
path: root/dev-util/ccache/ccache-3.7.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/ccache/ccache-3.7.11.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/ccache/ccache-3.7.11.ebuild')
-rw-r--r--dev-util/ccache/ccache-3.7.11.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/dev-util/ccache/ccache-3.7.11.ebuild b/dev-util/ccache/ccache-3.7.11.ebuild
deleted file mode 100644
index 04f64dcc7b6a..000000000000
--- a/dev-util/ccache/ccache-3.7.11.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="fast compiler cache"
-HOMEPAGE="https://ccache.dev/"
-SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-
-DEPEND="app-arch/xz-utils
- sys-libs/zlib"
-RDEPEND="${DEPEND}
- dev-util/shadowman
- sys-apps/gentoo-functions"
-# clang-specific tests use dev-libs/elfutils to compare objects for equality.
-# Let's pull in the dependency unconditionally.
-DEPEND+="
- test? ( dev-libs/elfutils )"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
- "${FILESDIR}"/${PN}-3.7.10-objdump.patch
-)
-
-src_prepare() {
- default
-
- sed \
- -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
- "${FILESDIR}"/ccache-config-3 > ccache-config || die
-
- # mainly used in tests
- tc-export OBJDUMP
-}
-
-src_configure() {
- econf --without-bundled-zlib
-}
-
-src_compile() {
- emake V=1
-}
-
-src_test() {
- emake check V=1
-}
-
-src_install() {
- DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
- default
-
- dobin ccache-config
- insinto /usr/share/shadowman/tools
- newins - ccache <<<"${EPREFIX}/usr/lib/ccache/bin"
-}
-
-pkg_prerm() {
- if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
- eselect compiler-shadow remove ccache
- fi
-}
-
-pkg_postinst() {
- if [[ ${ROOT:-/} == / ]]; then
- eselect compiler-shadow update ccache
- fi
-}