summaryrefslogtreecommitdiff
path: root/dev-util/buildbot/buildbot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-util/buildbot/buildbot-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-util/buildbot/buildbot-9999.ebuild')
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild55
1 files changed, 32 insertions, 23 deletions
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index d59c41b23e9b..35a2e69c15ec 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_REQ_USE="sqlite"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
[[ ${PV} == *9999 ]] && inherit git-r3
-inherit readme.gentoo-r1 user systemd distutils-r1
+inherit readme.gentoo-r1 systemd distutils-r1
MY_PV="${PV/_p/.post}"
MY_P="${PN}-${MY_PV}"
@@ -29,6 +31,7 @@ IUSE="crypt doc docker examples irc test"
RESTRICT="!test? ( test )"
RDEPEND="
+ acct-user/buildbot
>=dev-python/jinja-2.1[${PYTHON_USEDEP}]
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
>=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
@@ -38,12 +41,13 @@ RDEPEND="
>=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
>=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
crypt? (
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt]
>=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
+ <dev-python/idna-2.9[${PYTHON_USEDEP}]
dev-python/service_identity[${PYTHON_USEDEP}]
)
irc? (
@@ -51,46 +55,55 @@ RDEPEND="
)
docker? (
>=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
)
"
DEPEND="${RDEPEND}
- >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
doc? (
>=dev-python/sphinx-1.4.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-2.1.0[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-blockdiag[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
dev-python/pyenchant[${PYTHON_USEDEP}]
- >=dev-python/docutils-0.8[${PYTHON_USEDEP}]
- <dev-python/docutils-0.13.0[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
dev-python/sphinx-jinja[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
test? (
- >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
dev-python/moto[${PYTHON_USEDEP}]
- dev-python/boto3[${PYTHON_USEDEP}]
- dev-python/pyjade[${PYTHON_USEDEP}]
- dev-python/txgithub[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.12.48[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pypugjs[${PYTHON_USEDEP}]
dev-python/txrequests[${PYTHON_USEDEP}]
dev-python/lz4[${PYTHON_USEDEP}]
dev-python/treq[${PYTHON_USEDEP}]
dev-python/setuptools_trial[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
- >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt]
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ <dev-python/idna-2.9[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )
)"
+# >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
S=${WORKDIR}/${MY_P}
[[ ${PV} == *9999 ]] && S=${S}/master
if [[ ${PV} != *9999 ]]; then
PATCHES=(
- "${FILESDIR}/Remove-distro-version-test.patch"
+ "${FILESDIR}/Add-gentoo-to-the-VERSION_ID-check-exclusion.patch"
+ "${FILESDIR}/pypugjs.patch"
)
fi
-pkg_setup() {
- enewuser buildbot
+distutils_enable_tests setup.py
+pkg_setup() {
DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
to support starting buildbot through Gentoo's init system. To use this,
execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
@@ -115,7 +128,7 @@ src_install() {
doman docs/buildbot.1
if use doc; then
- dohtml -r docs/_build/html/
+ HTML_DOCS=( docs/_build/html/ )
# TODO: install man pages
fi
@@ -133,12 +146,6 @@ src_install() {
readme.gentoo_create_doc
}
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}
-
pkg_postinst() {
readme.gentoo_print_elog
@@ -194,7 +201,7 @@ pkg_config() {
mkdir --parents "${buildmaster_path}" || die "Unable to create directory ${buildmaster_path}"
fi
"${buildbot}" create-master "${instance_path}" &>/dev/null || die "Creating instance failed"
- chown --recursive buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ chown --recursive buildbot:buildbot "${instance_path}" || die "Setting permissions for instance failed"
mv "${instance_path}/master.cfg.sample" "${instance_path}/master.cfg" \
|| die "Moving sample configuration failed"
ln --symbolic --relative "/etc/init.d/buildmaster" "/etc/init.d/buildmaster.${instance_name}" \
@@ -202,6 +209,8 @@ pkg_config() {
if [[ ! -d "${instance_log_path}" ]]; then
mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ chown --recursive buildbot:buildbot "${instance_log_path}" \
+ || die "Setting permissions for instance failed"
fi
ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
|| die "Unable to create link to log file"