summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
commit7f740fcb9a0165d81bfecf7fb5da647763d76a1b (patch)
tree45dab58d8bd40ef97234398e9e1850495ea60273 /dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild
parent0bf5c5a0b1ff93d1f4aaa8cdea6acda5e42c2068 (diff)
gentoo auto-resync : 23:09:2022 - 05:29:13
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild
new file mode 100644
index 000000000000..b67bfb3e65bf
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-wsgi-dashboards/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"