summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
commit404b23b9395fafe5c40a1fd4d859c6cd17b4a646 (patch)
tree789ba7b9b17a99ad3ccbf05a131086babface825 /dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild
parent633a3741c9483bd63e8c29b276d2af636ec8b390 (diff)
gentoo auto-resync : 14:03:2024 - 06:47:03
Diffstat (limited to 'dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild')
-rw-r--r--dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild b/dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild
new file mode 100644
index 000000000000..a3fb0a32bd39
--- /dev/null
+++ b/dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-react-wsgi-dashboards/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-react-${PV}[${PYTHON_USEDEP}]
+"