summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-pkg/buildbot-pkg-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-util/buildbot-pkg/buildbot-pkg-3.4.0.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-3.4.0.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.4.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.4.0.ebuild
new file mode 100644
index 000000000000..e7729822e3ed
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-3.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-pkg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+RESTRICT="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e "/version/s/=.*$/=\"${MY_PV}\",/" -i setup.py || die
+ distutils-r1_src_prepare
+}