summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-pkg/buildbot-pkg-0.9.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/buildbot-pkg/buildbot-pkg-0.9.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-0.9.10.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-0.9.10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-0.9.10.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-0.9.10.ebuild
new file mode 100644
index 000000000000..dd96a049c7cf
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-0.9.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-pkg"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}