summaryrefslogtreecommitdiff
path: root/dev-util/bpftrace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-util/bpftrace/files
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-util/bpftrace/files')
-rw-r--r--dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch b/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
index 03fd2d13e602..fb75f9db1ba3 100644
--- a/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
+++ b/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
@@ -52,10 +52,10 @@ index 0361cdaa..f9c536a3 100644
if (LIBBPF_BTF_DUMP_FOUND)
target_include_directories(libbpftrace PUBLIC ${LIBBPF_INCLUDE_DIRS})
diff --git a/src/arch/CMakeLists.txt b/src/arch/CMakeLists.txt
-index 76bb217e..6d243a7e 100644
+index 76bb217e..4ad0f626 100644
--- a/src/arch/CMakeLists.txt
+++ b/src/arch/CMakeLists.txt
-@@ -1,15 +1,15 @@
+@@ -1,15 +1,17 @@
if(CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
- add_library(arch aarch64.cpp)
+ add_library(bpftracearch aarch64.cpp)
@@ -76,6 +76,8 @@ index 76bb217e..6d243a7e 100644
else()
message(FATAL_ERROR "Unsupported architecture: ${CMAKE_SYSTEM_PROCESSOR}")
endif()
++
++install(TARGETS bpftracearch LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/src/ast/CMakeLists.txt b/src/ast/CMakeLists.txt
index 5234388c..8b40faaa 100644
--- a/src/ast/CMakeLists.txt