summaryrefslogtreecommitdiff
path: root/dev-util/bpftrace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-util/bpftrace/files
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-util/bpftrace/files')
-rw-r--r--dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch (renamed from dev-util/bpftrace/files/bpftrace-0.11.0-install-libs.patch)83
1 files changed, 35 insertions, 48 deletions
diff --git a/dev-util/bpftrace/files/bpftrace-0.11.0-install-libs.patch b/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
index a28e37564eae..03fd2d13e602 100644
--- a/dev-util/bpftrace/files/bpftrace-0.11.0-install-libs.patch
+++ b/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
@@ -1,8 +1,8 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1bca8d6..1482b29 100644
+index e33bb1ca..52e1fa25 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -91,9 +91,10 @@ find_package(FLEX REQUIRED)
+@@ -100,9 +100,10 @@ find_package(FLEX REQUIRED)
bison_target(bison_parser src/parser.yy ${CMAKE_BINARY_DIR}/parser.tab.cc VERBOSE)
flex_target(flex_lexer src/lexer.l ${CMAKE_BINARY_DIR}/lex.yy.cc)
add_flex_bison_dependency(flex_lexer bison_parser)
@@ -17,7 +17,7 @@ index 1bca8d6..1482b29 100644
include(CheckSymbolExists)
set(CMAKE_REQUIRED_DEFINITIONS -D_GNU_SOURCE)
diff --git a/resources/CMakeLists.txt b/resources/CMakeLists.txt
-index a95c60a..f5c4d67 100644
+index a95c60a1..f5c4d676 100644
--- a/resources/CMakeLists.txt
+++ b/resources/CMakeLists.txt
@@ -1,6 +1,7 @@
@@ -31,24 +31,31 @@ index a95c60a..f5c4d67 100644
function(embed_headers output)
file(WRITE ${output} "#include \"headers.h\"\n\nnamespace bpftrace {\n")
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 487fa9b..61b7b38 100644
+index 0361cdaa..f9c536a3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -84,7 +84,8 @@ if (ALLOW_UNSAFE_PROBE)
- target_compile_definitions(bpftrace PRIVATE HAVE_UNSAFE_PROBE)
- endif(ALLOW_UNSAFE_PROBE)
+@@ -49,6 +49,7 @@ add_executable(${BPFTRACE}
+ )
+
+ install(TARGETS ${BPFTRACE} DESTINATION ${CMAKE_INSTALL_BINDIR})
++install(TARGETS libbpftrace LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ target_link_libraries(${BPFTRACE} libbpftrace)
+
+ if (BUILD_FUZZ)
+@@ -109,7 +110,7 @@ if(STATIC_LINKING)
+ endif(STATIC_LINKING)
--target_link_libraries(bpftrace arch ast parser resources)
-+target_link_libraries(bpftrace bpftracearch bpftraceast bpftraceparser
-+ bpftraceresources)
- target_link_libraries(bpftrace ${LIBBCC_LIBRARIES})
- if(STATIC_LINKING)
+-target_link_libraries(libbpftrace parser resources ast arch)
++target_link_libraries(libbpftrace bpftraceparser bpftraceresources bpftraceast bpftracearch)
+
+ if (LIBBPF_BTF_DUMP_FOUND)
+ target_include_directories(libbpftrace PUBLIC ${LIBBPF_INCLUDE_DIRS})
diff --git a/src/arch/CMakeLists.txt b/src/arch/CMakeLists.txt
-index a26c1c8..ffb5900 100644
+index 76bb217e..6d243a7e 100644
--- a/src/arch/CMakeLists.txt
+++ b/src/arch/CMakeLists.txt
-@@ -1,13 +1,15 @@
+@@ -1,15 +1,15 @@
if(CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
- add_library(arch aarch64.cpp)
+ add_library(bpftracearch aarch64.cpp)
@@ -63,13 +70,14 @@ index a26c1c8..ffb5900 100644
elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
- add_library(arch x86_64.cpp)
+ add_library(bpftracearch x86_64.cpp)
+ elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL "mips64")
+- add_library(arch mips64.cpp)
++ add_library(bpftracearch mips64.cpp)
else()
message(FATAL_ERROR "Unsupported architecture: ${CMAKE_SYSTEM_PROCESSOR}")
endif()
-+
-+install(TARGETS bpftracearch LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/src/ast/CMakeLists.txt b/src/ast/CMakeLists.txt
-index 649bf0a..b969b9c 100644
+index 5234388c..8b40faaa 100644
--- a/src/ast/CMakeLists.txt
+++ b/src/ast/CMakeLists.txt
@@ -1,4 +1,4 @@
@@ -78,9 +86,9 @@ index 649bf0a..b969b9c 100644
ast.cpp
attachpoint_parser.cpp
codegen_llvm.cpp
-@@ -7,17 +7,18 @@ add_library(ast
- printer.cpp
- semantic_analyser.cpp
+@@ -13,17 +13,18 @@ add_library(ast
+ signal.cpp
+ visitors.cpp
)
+install(TARGETS bpftraceast LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
@@ -103,21 +111,14 @@ index 649bf0a..b969b9c 100644
if (STATIC_LINKING)
set(clang_libs
-@@ -41,17 +42,17 @@ if (STATIC_LINKING)
- if(EMBED_LIBCLANG_ONLY)
- unlink_transitive_dependency("${CLANG_EXPORTED_TARGETS}" "LLVM")
- endif()
-- target_link_libraries(ast ${CLANG_EMBEDDED_CMAKE_TARGETS})
-+ target_link_libraries(bpftraceast ${CLANG_EMBEDDED_CMAKE_TARGETS})
- else()
- list(INSERT clang_libs 0 libclang.a)
- endif()
+@@ -54,11 +55,11 @@ if (STATIC_LINKING)
+
- if(EMBED_LLVM)
-- target_link_libraries(ast ${LLVM_EMBEDDED_CMAKE_TARGETS})
-+ target_link_libraries(bpftraceast ${LLVM_EMBEDDED_CMAKE_TARGETS})
+ if(EMBED_USE_LLVM)
+- target_link_libraries(ast "-Wl,--start-group" ${CLANG_EMBEDDED_CMAKE_TARGETS} ${LLVM_EMBEDDED_CMAKE_TARGETS} "-Wl,--end-group")
++ target_link_libraries(bpftraceast "-Wl,--start-group" ${CLANG_EMBEDDED_CMAKE_TARGETS} ${LLVM_EMBEDDED_CMAKE_TARGETS} "-Wl,--end-group")
else()
- llvm_map_components_to_libnames(llvm_libs bpfcodegen ipo irreader mcjit option orcjit ${LLVM_TARGETS_TO_BUILD})
+ llvm_map_components_to_libnames(llvm_libs ${llvm_lib_names})
- target_link_libraries(ast ${clang_libs})
- target_link_libraries(ast ${llvm_libs})
+ target_link_libraries(bpftraceast ${clang_libs})
@@ -125,7 +126,7 @@ index 649bf0a..b969b9c 100644
endif()
if(STATIC_LIBC)
-@@ -60,11 +61,11 @@ if (STATIC_LINKING)
+@@ -68,11 +69,11 @@ if (STATIC_LINKING)
else()
find_library(found_LLVM LLVM HINTS ${LLVM_LIBRARY_DIRS})
if(found_LLVM)
@@ -140,17 +141,3 @@ index 649bf0a..b969b9c 100644
- target_link_libraries(ast libclang)
+ target_link_libraries(bpftraceast libclang)
endif()
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index 4104a57..59486de 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -101,7 +101,8 @@ if(HAVE_BFD_DISASM)
- endif(STATIC_LINKING)
- endif(HAVE_BFD_DISASM)
-
--target_link_libraries(bpftrace_test arch ast parser resources)
-+target_link_libraries(bpftrace_test bpftracearch bpftraceast bpftraceparser
-+ bpftraceresources)
-
- target_link_libraries(bpftrace_test ${LIBBCC_LIBRARIES})
- if (STATIC_LINKING)