summaryrefslogtreecommitdiff
path: root/dev-util/bnfc/bnfc-2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/bnfc/bnfc-2.8.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/bnfc/bnfc-2.8.ebuild')
-rw-r--r--dev-util/bnfc/bnfc-2.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/bnfc/bnfc-2.8.ebuild b/dev-util/bnfc/bnfc-2.8.ebuild
new file mode 100644
index 000000000000..661b7ce9b92e
--- /dev/null
+++ b/dev-util/bnfc/bnfc-2.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="BNFC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A compiler front-end generator"
+HOMEPAGE="http://bnfc.digitalgrammars.com/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT=test # missing files
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.8
+ dev-haskell/happy
+ test? ( >=dev-haskell/doctest-0.8
+ dev-haskell/hspec
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/temporary )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-alex-3.1.6.patch
+}