summaryrefslogtreecommitdiff
path: root/dev-util/bnfc/bnfc-2.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/bnfc/bnfc-2.8.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/bnfc/bnfc-2.8.3.ebuild')
-rw-r--r--dev-util/bnfc/bnfc-2.8.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/bnfc/bnfc-2.8.3.ebuild b/dev-util/bnfc/bnfc-2.8.3.ebuild
new file mode 100644
index 000000000000..517ae82b955c
--- /dev/null
+++ b/dev-util/bnfc/bnfc-2.8.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="BNFC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A compiler front-end generator"
+HOMEPAGE="http://bnfc.digitalgrammars.com/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.8.0.2
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.16.0
+ dev-haskell/happy
+ test? ( >=dev-haskell/doctest-0.8
+ dev-haskell/hspec
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/temporary )
+"
+
+S="${WORKDIR}/${MY_P}"