summaryrefslogtreecommitdiff
path: root/dev-util/bitrise/bitrise-1.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-util/bitrise/bitrise-1.20.0.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-util/bitrise/bitrise-1.20.0.ebuild')
-rw-r--r--dev-util/bitrise/bitrise-1.20.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/bitrise/bitrise-1.20.0.ebuild b/dev-util/bitrise/bitrise-1.20.0.ebuild
new file mode 100644
index 000000000000..3a7a162eac9d
--- /dev/null
+++ b/dev-util/bitrise/bitrise-1.20.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Run your Bitrise.io automations on any Mac or Linux machine"
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-util/envman-1.2.0
+ >=dev-util/stepman-0.10.0"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ default
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/bitrise" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/bitrise || die "Couldn't compile bitrise"
+}
+
+src_test() {
+ pushd "${S}/_tests/integration/" || die "Couldn't find integration tests directory"
+ rm envstore_test.go exit_code_test.go global_flag_test.go json_params_test.go log_filter_test.go output_alias_test.go \
+ step_template_test.go trigger_params_test.go update_test.go timeout_test.go || die "Couldn't remove network-dependent tests"
+ popd || die "Couldn't return to ${S} directory"
+ export PULL_REQUEST_ID=""
+ export INTEGRATION_TEST_BINARY_PATH="${S}/bin/bitrise"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/bitrise
+ dodoc README.md
+ use doc && dodoc -r _docs
+}