summaryrefslogtreecommitdiff
path: root/dev-util/bcpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-10 09:27:33 +0000
commite80777b54c5b430ca044e16878f59a2020423d48 (patch)
treeb72b3422d129532b8f0ceb415c6e7c5109e3fe75 /dev-util/bcpp
parentaa61828f226f3b30e6939408847d914a145fdf35 (diff)
gentoo auto-resync : 10:11:2022 - 09:27:33
Diffstat (limited to 'dev-util/bcpp')
-rw-r--r--dev-util/bcpp/Manifest3
-rw-r--r--dev-util/bcpp/bcpp-20221002.ebuild40
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/bcpp/Manifest b/dev-util/bcpp/Manifest
index 04ee5548b05d..306071c044e0 100644
--- a/dev-util/bcpp/Manifest
+++ b/dev-util/bcpp/Manifest
@@ -1,3 +1,6 @@
DIST bcpp-20210108.tgz 150080 BLAKE2B 5614b1e9957d63532ed6ba6d4588ae8b899201c363984bc99726bf48ae49ee9d16a71c407e3988fdeb715fef5e67343bc56c94eb1c8e977a14a6c2b08ee6668a SHA512 46a8fff766bbca4833c898d550ce4f0ac5e6ea64a2e05e63e4680186345a080aa30e54a4a5a3d22d47df8e8c8cbc4e738578fd59ec647d305c32a228d3b01e73
+DIST bcpp-20221002.tgz 151426 BLAKE2B 6978b30ca684ec5e9eb781955679d333e7efdb389af2b29a341b466387bf4147bc72c54d80eaa6d57770cd720c2074881594418ccbe7aa81241ebeac938499e3 SHA512 a1d2c57e5acabf90f19d3721c79f76867c2b93af51b717af80089ab9dc5117ac28263ceb6aff6544a1040b6fc5115a229759631309c4f6ea9808c6b6eb7d1c92
+DIST bcpp-20221002.tgz.asc 729 BLAKE2B 64a211fb84ac6ca2926cb54b06945a908bb19ef15fb8784f4201b29dbc1ebe1be85e8bb0d05d14ebde126508cb33bb9e2d2411fa54b1290246263829d1f4f7f0 SHA512 867b2c04c957daff028a0eaa14ce2c7fd8718dbe9a9af5bf46b293ce51a0a49f823b18978f10f77b7363ff62691683e2945d0d71280185386f19dc7f1cc883d5
EBUILD bcpp-20210108.ebuild 903 BLAKE2B 3748ffc0caa34f1a2a64e29bd7f586406ff45ac63ad6b9fa4a5bc6eb90040d71df74eba132ada63340b1e450d90d961de1e02c6e1921d5395d2ff8771eb7a916 SHA512 59c925ed7e6bd7015bdef7febdc9682e424793df4e568f70b5fc641d2fc65f286deb9b5d421af9159496871a64507c97a896274ac03e430a97f95369ae771f07
+EBUILD bcpp-20221002.ebuild 1160 BLAKE2B f2a1011fd6e3602833bbad59cc2de8084a257ecde8391ac6465b33cb7f560d3af558f62a425fed8e4f329dc42213ca96dd7642c81a5ef8178db1d5eff84202c1 SHA512 1ae3b0e4c0d908cc4baf4b808c759fbd6f4cfe68deffcf2f78b2b22955070f1c8ee219ba94050989dfe717666a935184fcff6c1d00c0afe4f006104de4a03bcd
MISC metadata.xml 327 BLAKE2B 98cfc008c1157e6c7bf26938ee9cb85afed7b4ca15f625a6bfb4f10a4a7ec9b7ad101c38c6b5bde51ac8ff8f6ebc15ca0cdd2903db65f1d691c13f534f5783e1 SHA512 ebaa5a7e3f02bc91337c50366007ffb65ef5a8a5604c43872d3a45f50a372adca5ac279b84309e3045fd34b81d0a9a138d2f73141955e15f0e827a42fab70673
diff --git a/dev-util/bcpp/bcpp-20221002.ebuild b/dev-util/bcpp/bcpp-20221002.ebuild
new file mode 100644
index 000000000000..08c0120f1997
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20221002.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="https://invisible-island.net/bcpp/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
+
+src_compile() {
+ emake CPPFLAGS='-DBCPP_CONFIG_DIR=\"/etc/bcpp/\"'
+}
+
+src_install() {
+ default
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at ${EPREFIX}/etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}