summaryrefslogtreecommitdiff
path: root/dev-util/bcpp/bcpp-20230130.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 09:07:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 09:07:02 +0000
commit68f980204de6c2d69eed8748edc90282879326a6 (patch)
treeeb74f0bcca207f547c8ababe0f82e65e16b30ce1 /dev-util/bcpp/bcpp-20230130.ebuild
parentc8273339188289fe8571e5a8cb9e00e59a46aaaf (diff)
gentoo auto-resync : 02:02:2023 - 09:07:02
Diffstat (limited to 'dev-util/bcpp/bcpp-20230130.ebuild')
-rw-r--r--dev-util/bcpp/bcpp-20230130.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/bcpp/bcpp-20230130.ebuild b/dev-util/bcpp/bcpp-20230130.ebuild
new file mode 100644
index 000000000000..f5beeb1bf188
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20230130.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="https://invisible-island.net/bcpp/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
+
+src_compile() {
+ emake CPPFLAGS='-DBCPP_CONFIG_DIR=\"/etc/bcpp/\"'
+}
+
+src_install() {
+ default
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at ${EPREFIX}/etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}